Printed Circuit Board Assembly & PCB Design SMT Electronics Assembly Manufacturing Forum

Printed Circuit Board Assembly & PCB Design Forum

SMT electronics assembly manufacturing forum.


Mydata My9 X MOT motor timeout

Views: 1816

#88088

Mydata My9 X MOT motor timeout | 12 June, 2022

I'm having a problem with my Mydata My9 pick and place. Basically whenever I try to run the placement calibration program or try to have the machine find fiducials, or basically anything with precision, the machine displays a X MOT motor timeout error. In the service manual, it just says hardware problem. Would anyone have any idea on where I could start looking? It seems to have a MOT3d board as the driver and so I don't believe I can swap it with other MOT boards?

reply »

#88089

Mydata My9 X MOT motor timeout | 12 June, 2022

I forgot to mention that I've measured and adjusted the cog play on the x axis and so it is within range, if that applies.

reply »

#88097

Mydata My9 X MOT motor timeout | 14 June, 2022

Start with fundamentals:

Disconnect, clean and reconnect all inner connections, bulk heads, ext. Disconnect, reconnect all connections at the controller. Check wiring harness for conductivity. Clean everything appropriately, lube ways, balls screws ext.

Time outs usually mean something is not responding to the controller in a way it expects, maybe you have an encoder that is going bad?

reply »

#88099

Mydata My9 X MOT motor timeout | 14 June, 2022

Thanks! I just needed a response like that. I will do all that, and if it's still an issue, I'll change the x wagon encoder right?

There are three encoders on the x wagon though? The white one on the x carriage, the white one on the x belt drive motor and then the larger x wagon motor. Which one could be the culprit if it came down to that?

reply »

#88100

Mydata My9 X MOT motor timeout | 14 June, 2022

Cant put a finger on it being an encoder that was just a single possibility. You can always hook up a scope to the encoder and see if they are working appropriately.

I would look through the machine's utilities and see if there is some debug or more information you can get.

To determine if the feedback is working in your system you can move the axis manually and see if the coordinates respond correctly.

reply »

#88102

Mydata My9 X MOT motor timeout | 15 June, 2022

Hey All. I figured it out. It turns out that the problem was simply a loose coupler on the x wagon motor transducer. I had only checked one screw in the past but the other screw was apparently loose as well.

reply »

Fluid Dispensers

Electronics Equipment Consignment